Skip to content

Wer billig kauft, kauft zweimal

Seit fast einem Jahr haengt zwischen meinem Standrechner und meinem Router ein GB/s-Switch den ich mal fuer 12Euro wo mitbestellt hatte. Gestern ist es aber zum  Eklat gekommen:


Kurz nachdem ich eine GIGAntische Menge an nichtweiter-zu-spezifizierenden Daten zwischen PC und Notebook ausgetauscht habe war das Internet am PC kaputt.
Ping PC->router zeigte einen Verlust von knapp 30%, ping PC->Notebook(wlan-nic) ebenfalls und im tcpdump am Notebook tauchte auch nicht jedes pingpaket auf. Da ich keine doppelt vergebenen IPs/MACs finden konnte habe ich, mehr aus einer Not an mangelnden Ideen, den Switch am Schreibtisch gepowercycled und siehe da: Alles geht wieder.


Im Nachinein betrachtet musste ich auch feststellen, das die Geschwindigkeit des Eingangs erwaehnten Datentransfers doch beachtlich abgenommen haben muss. So hatte ich am Anfang noch 30MB/s beobachtet, eine Ueberschlagsrechnung von der Gesamtmenge / Zeit  bringt es aber auf unter 5MB/s.


Wenn sich das haeuft, werd ich mir wohl einen neuen Switch besorgen muessen... Hat da wer gute Erfahrung und eine Empfehlung?

Serendipity Blogsoftware, PHP 5 und Strict-mode

Meine Blogsoftware warf nachdem update auf Wheezy einen Haufen an PHP-Warnings.


Die Fehlerquelle war schnell gefunden (die meisten plugins benutzten die Blog-API nicht ganz nach PHP-spezifikation), die Loesung war auch schon in naehe: Ein update auf 1.7_rc3 mit automatischen update der plugins.


Leider verlief das dann doch nicht so wie im updateguide angegeben... /: Hier aber im schnellen meine Loesungen zum Erfolg:





  • baseURL braucht jetzt ein trailing '/'

  • serendipityHTTPPath muss stimmen (per weboberflaeche aendern!! nicht in der mysqldb, weil da noch ein paar hooks dranhaengen)

  • Einen anderen Style auswaehlen, damit das neugenerieren des Styles neu angeschmissen wird

  • aus der .htaccess multiview auskommentieren (das liegt wohl an der lokalen Serverconfig hier)



schlechter Youtube Empfang

Entweder ich bin ungewollt Opfer vom einer 1.April-Betaversion von youtube oder irgendwas zwischen flash's Binaerdatei und Arbeitsspeicher ist leicht kaputt.

Zumindest sind meine Youtubevideos mit rauschen ueberlagert:
Youtube rauscht


Und JA: Auf einem anderem Rechner sieht genau dieses Video gut aus.